注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

云之南

风声,雨声,读书声,声声入耳;家事,国事,天下事,事事关心

 
 
 

日志

 
 
关于我

专业背景:计算机科学 研究方向与兴趣: JavaEE-Web软件开发, 生物信息学, 数据挖掘与机器学习, 智能信息系统 目前工作: 基因组, 转录组, NGS高通量数据分析, 生物数据挖掘, 植物系统发育和比较进化基因组学

网易考拉推荐

安装GD(gd-2.0.35)安装  

2010-10-09 16:52:49|  分类: linux&shell |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
安装GD(gd-2.0.35)
 
安装LibPNG
 
1.下载
 
2.编译安装
#tar -xzf libpng-1.2.23.tar.gz    
#cd libpng-1.2.23                 
#cp scripts/makefile.linux makefile
(此处没有./configure)
#make       
#make install
 
安装JPEG:
1.下载
 
2.编译安装
#tar -xzf jpegsrc.v6b.tar.gz
#cd jpegsrc.v6b             
#./configure --enable-shared
#make                       
#make instll                
 
最后一步出错:
解决方法:
  #mkdir /usr/local/man/man1
 
安装gd
#tar xzvf gd-2.0.35.tar.gz
#cd gd-2.0.35
#./configure --prefix=/usr/local/gd2
#make
 
出错如下:
cd .&&/bin/sh/usr/local/tarballs/gd-2.0.35/config/missing --run aclocal-1.9 -I config
/usr/local/tarballs/gd-2.0.35/config/missing:line46:aclocal-1.9:command not found
WARNING: 'alcocal-1.9' is missing on your system.you should only need it is you modified 'acinclude.m4' or 'configure.ac'. you might want to install the 'Automake' and 'perl' packages.Grab them from any GNU archive site.
cd . && /bin/sh/usr/local/tarballs/gd-2.0.35/config/missing --run automake-1.9--foreign
/usr/local/tarballs/gd-2.0.35/config/missing:line 46:sutomake-1.9:command ont found
WARNING:'automake-1.9' is missing on your system.you should only need it is you modified 'makefile.am','acinclude.m4' or 'configure.am'.you might want to install the 'automake' and 'pe             rl'package.
grab them from any GNU archive site.
..................
(此处出错如图error1,有待处理)
 
解决办法:
 
  1.下载autoconf2-2.61.tar.gz
 
 
  2.找到autoconf的位置

   #rpm -qf /usr/bin/autoconf
   #find / -name autoconf   
    autoconf-2.57-3         

  3.编译安装
 
  #tar -xzf autoconf-2.61.tar.gz         
  #./configure --prefix=/usr/local     
  #make                           
  #rpm -e --nodeps autoconf-2.57-3
  #make install                  
 
  4.测试版本
 
   #find / -name autoconf
   /usr/bin/autoconf
   ....................   
 
 
   #cd /usr/local/bin    
   #./autoconf --version
   atutoconf-2.61      

另外,还有可能还要安装  freetype-2.3.12  ,然后

安装gd
#tar xzvf gd-2.0.35.tar.gz
#cd gd-2.0.35
#./configure --prefix=/opt/gd-2.0.35 --with-freetype=/opt/freetype-2.3.12/lib

#make
#make install

 
  评论这张
 
阅读(4962)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2016